Blackmagic Troubleshooting

Introduction:

The information below outlines some basic troubleshooting steps you can take if you are having issues getting your Blackmagic device to appear in Wirecast. All of these steps assume a you are using MacBook. 

Basic Steps:

When using USB 3.0 or Thunderboldt the first thing you always want to do is confirm that the computer is recognizing the device is plugged into the computer. To do this, follow the steps below:

  1. Go to the Apple menu and select "About this Mac"
  2. Select "More Info" and then "System Report"
  3. On the left side, click on the Thunderboldt option. From there, make sure that the device is listed. If it isn't, confirm that the Thunderboldt cable is plugged in. If it is, have them unplug it then plug it back in to see if you can get it to show in the system report. You can also have them switch the cable around which has gotten devices to show up in the past. 

If the device is showing in the System Report, follow the steps below to troubleshoot the device:

  1. Confirm through Desktop Video in the System Preferences that the input is set to whatever source you are using.
  2. Toggle video format in Source Settings(Within Wirecast) off of 1080i59.94 then back onto it. 
  3. Uncheck and then recheck Deinterlace Video. 
  4. Delete shot and then remove it from the Asset Manager under the Media tab. Add the shot in again. 
  5. Update to the latest version of Desktop Video at blackmagicdesign.com/support. The computer will need to restart after this software installs. 

If none of these steps get the video up and running, don't hesitate to reach out to us for further assistance!

Still need help? Contact Us Contact Us